Results 1 to 2 of 2

Thread: openGL ES software implementation for clutter

  1. #1
    Junior Member
    Join Date
    Dec 2009
    Posts
    1

    openGL ES software implementation for clutter

    hi,


    I am trying to compile clutter on openGL ES 1.1(i.e gles1.0) with backend eglnative .The clutter application is configured with following option:
    ./configure --with-flavour=eglnative --with-gles=1.1 --with-x=no

    source compiled with some modification in clutter/cogl.But while building test application ,I am getting error :
    CCLD test-conformance
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glTexEnvfv'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glIsEnabled'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glTexEnvi'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glAlphaFunc'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glColor4ub'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glClearColor'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glDeleteBuffers'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glFogfv'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glFogf'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glLoadMatrixf'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glGenBuffers'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glMaterialfv'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `glIsTexture'
    ../../clutter/.libs/libclutter-eglnative-1.0.so: undefined reference to `CLUTTER_UNITS_FROM_DEVICE'

    I am using clutter-1.1.2 and gles1.0

    please help me.

    ~regards
    bhadraji

  2. #2

    Re: openGL ES software implementation for clutter

    I don't know anything about cuttter, but those missing symbols are not defined in gles1.0, however they are defined in gles1.1. So it looks like you need to link against a gles1.1 implementation or modify cutter to be compatible with gles1.0. I'm not sure about some other missing symbols, but this is a good first step. Can you configure with gles1.0 (e.g. ./configure --with-flavour=eglnative --with-gles=1.0 --with-x=no)?

Similar Threads

  1. OpenCL Software implementation.
    By Shadrach in forum OpenCL
    Replies: 1
    Last Post: 06-03-2010, 12:42 PM
  2. Companies offering OpenGL ES software renderer
    By steru in forum OpenGL ES 1.X - fixed function hardware
    Replies: 3
    Last Post: 12-17-2008, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •