Hi everyone,

After having some troubles with RGBA textures, I realized that the glTexImage2D(target, level, Image) assumes by default textures with premultiplied alpha,
so it unmultiplies source texels before sending data to the GL. The optional fourth parameter (glTexImage2D(target, level, Image, false)) seems to be ignored both in Chrome and Firefox nightly builds.
Crawling webkit and firefox source code somewhat confirmed my suspicion.
As a result I am not able to use textures with alpha channel.
Premultiplying the source RGB is not an option because it is in general a lossy procedure.
Am I missing something? Has anyone faced the same problem? Is there a workaround or we just have to wait until they fix the potential bug?

Thanks,
Marco.