I'm testing conformance of openMAXIL. but in case of WaitForResourceTest,
Error happens in the line#453(OMX_CONF_WaitForResourcesTest.c) because of
the more instantiation(my MAX_COMPONENT_VIDEODEC = 4), then

My question is that next seq. (4~5 as below) is not progressed.
/* ---------------------------------------
* 1. Load component
* 2. Transition to idle
* 3. Repeat from steps 1-3 until transition to idle returns
* OMX_ErrorInsufficientResources and transitions to Wait state
* 4. Switch one of the previous components to the loaded state to free resources
* 5. Verify the component in the WaitForResources state transitions to idle
*/

My log is as below, What is the problem ? & What should I check ?

------------------------------------------------------------
OMX_CONF_AddTest WaitForResourcesTest
OMX_CONF_TestComponent OMX.sec.video_decoder.mpeg4
##
## WaitForResourcesTest
##
-Trying to create and idle instantiation 0 (priority = 100)
-Instantiation 0 changing to state OMX_StateIdle
-Trying to create and idle instantiation 1 (priority = 100)
-Instantiation 1 changing to state OMX_StateIdle
-Trying to create and idle instantiation 2 (priority = 100)
-Instantiation 2 changing to state OMX_StateIdle
-Trying to create and idle instantiation 3 (priority = 100)
-Instantiation 3 changing to state OMX_StateIdle
-Trying to create and idle instantiation 4 (priority = 100)
-!!! InteropProfileTests/OMX_CONF_WaitForResourcesTest.c:453 Error 80001000 OMX_ErrorInsufficientResources
-Cleaning up
-Instantiation 1 changing to state OMX_StateLoaded
-Instantiation 2 changing to state OMX_StateLoaded
-Instantiation 3 changing to state OMX_StateLoaded
*** WaitForResourcesTest OMX.sec.video_decoder.mpeg4 FAILED, 80001000 OMX_ErrorInsufficientResources

***
*** Summary for OMX.sec.video_decoder.mpeg4
***
*** 0 tests passed:
***
*** 1 tests failed:
*** WaitForResourcesTest
***