Results 1 to 6 of 6

Thread: Newbie needs your help

  1. #1
    Junior Member
    Join Date
    Jan 2007
    Posts
    4

    Newbie needs your help

    Hello all!

    I'm new to OpenGl ES and have some problems with my Axim x51v (Intel 2700 graphics accelerator) and Windows Mobile 5 (German Rom A04 - should be identical to English Rom A12).
    I'm trying to get started with the PowerVR SDK, but i'm stuck:

    I have VC2005 and the Microsoft PocketPC SDK installed. I also downloaded the Intel 2700g SDK and PowerVR SDK ("Windows Mobile 5.0 Pocket PC (Dell X51v)").
    Then i copied the libGLES_CM.lib from Intel's 2700 SDK to the appropriate folder in the PowerVR SDK (as stated in the userguide).
    And there's the first problem: i cannot find a libEGL.lib anywhere. According to the userguide this lib should also go into the PowerVR SDK folder...
    Anyway ... I tried to compile the demos (release, target: pocketpc). No problems here. Everything compiles fine - no errors, no warnings - until... i deploy the compiled exe to my pda (or copy it manually via active sync)
    I get an error message from my pda saying something like: the application cannot be started because it's either not signed or some of its components are missing.
    ???
    What's going on? I searched for opengl related stuff on my pda - the only thing i found is lib_GLES_CL.dll in the windows folder.
    Am i missing something? Doing something wrong? Too stupid??
    Please help!

    Michael

  2. #2
    Senior Member
    Join Date
    May 2006
    Posts
    353
    The libGLES_CL.lib (not CM, as Intel only supports the Common Lite profile) import library from the Intel 2700G SDK contains the EGL entry points, so you don't need to worry about the "missing" libEGL.lib.

    Do the precompiled binaries from the PowerVR SDK work? Which SDK version are you using?
    Georg Kolling, Imagination Technologies
    Please ask questions specific to PowerVR hardware or SDKs on the PowerVR Insider Forum
    DevTech@imgtec.com | http://www.powervrinsider.com

  3. #3
    Junior Member
    Join Date
    Jan 2007
    Posts
    4
    Hello

    oops - i confused something.
    You're right - in the intel 2700 SDK there's no libGLES_CM.lib but only a libGLES_CL.lib
    Obviously the ..CM.lib was from an old vincent package (???) on my hd, and i accidentally copied that one. Maybe that's not correct, but what else should i do?
    There's no ..CM.lib in the 2700 SDK and also not in the Microsoft PocketPC SDK...

    So where do i get the ..CM.lib file? Renaming the ..CL.lib from the 2700 SDK to ..CM.lib is surely not correct. Also trying to link against the ..CL.lib doesn't work..

    Next problem: Even the precompiled binaries from the powerVR SDK do not work.
    Same error from my pda: not signed or missing components

    I downloaded here:
    http://www.imgtec.com/PowerVR/inside...=PowerVRSDKs#1
    under OpenGL ES 1.x: link named "Windows Mobile 5.0 Pocket PC (Dell X51v)" and the required 2700 sdk

    btw: the precompiled binary that comes with the 2700 sdk works fine (but compiles correctly only for the mobile 2003 platform)

    Maybe i should stick to Direct3D... the direct 3d mobile sdk for the 2700 from the bottom of the named download page works right out of the box...

  4. #4
    Junior Member
    Join Date
    Jan 2007
    Posts
    4
    Aaah - things become clearer (i think)

    Correct me if i'm wrong:

    In the 2700 SDK there's only a ..CL.lib since the 2700 supports only the common lite profile.
    So i do not need to copy a ..CM.lib to the powerVR SDK but only this ..CL.lib
    Then i can only compile the "CommonLite Debug" and "CommonLite Release" configurations of the demos - which link to the ..CL.lib instead of the missing ..CM.lib
    But first i need to compile the SDK Tools (also for CommonLite) since the OGLEtools.lib does not come precompiled for CommonLite.

    Then the demos **should** compile and run... i thought
    Not really - i get a linker error:
    " unresolved external symbol __imp_eglSwapInterval referenced in ..."

    Well, still not working...

    Maybe the precompiled binaries also link against a ..CM.lib and need a ..CM.dll to run on the Pda?
    My x51v only has lib_GLES_CL.dll. Therefore i get the "missing component" error?

    Michael

  5. #5
    Junior Member
    Join Date
    Jan 2007
    Posts
    4
    Quote Originally Posted by MichaelS
    ... Then the demos **should** compile and run... i thought
    Not really - i get a linker error:
    " unresolved external symbol __imp_eglSwapInterval referenced in ..."
    That looks like an EGL 1.0/1.1 issue. I had a look at the lib you mention (libGLES_CL.lib), it only supports EGL 1.0 (eglSwapInterval is EGL 1.1).

    HTH

  6. #6
    Junior Member
    Join Date
    Jan 2007
    Posts
    4
    Hi again,

    and thanks for your comments.

    I got it working!!! The linker errors were in fact a version issue.
    I renamed the egl_1.0.h and gl_1.0.h in the include directory of the SDk to egl.h and gl.h and now everything compiles, links, and runs fine.
    No "missing components" errors anymore!

    Bye, Michael

Similar Threads

  1. Need help for a newbie
    By ccsophea in forum OpenGL ES general technical discussions
    Replies: 2
    Last Post: 02-07-2005, 12:06 AM
  2. Help a newbie
    By wmpang in forum OpenGL ES general technical discussions
    Replies: 6
    Last Post: 01-13-2005, 03:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •