Results 1 to 3 of 3

Thread: PowerVR SDK Windows OpenGL ES 1.1 Bug

  1. #1
    Junior Member
    Join Date
    Mar 2006
    Location
    Villingen-Schwenningen, Germany
    Posts
    11

    PowerVR SDK Windows OpenGL ES 1.1 Bug

    Hi all,

    I am using the above mentioned SDK and I recognized a bug when cleaning up EGL. My code crashes when calling eglMakeCurrent(eglDisplay, NULL, NULL, NULL);
    eglDisplay is valid and I also tried the EGL_NO_* flags. Same effect.

    I noticed, that the problem only occurs, if I am passing "a lot" of triangles to the engine during rendering.

    Has anyone encountered a similar problem? Any solutions to solve this problem?

    Regards Norbert

    By the way: The problem does not occur with the Rasteroid 3.1 SDK.

  2. #2
    Senior Member
    Join Date
    May 2006
    Posts
    353
    Hi,

    For problems with the PowerVR SDK or one of its components, it's best to contact us directly via email: devrel 'at' imgtec.com

    Do you get any error message or output to the debug console when running your application in a debugger? I suppose you mean triangles per frame, not just in total? If so, how many draw calls are you using per frame, and what is the size of your vertex arrays? Does the running time of your application make a difference?

    Regards,
    Georg
    Georg Kolling, Imagination Technologies
    Please ask questions specific to PowerVR hardware or SDKs on the PowerVR Insider Forum
    DevTech@imgtec.com | http://www.powervrinsider.com

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    Villingen-Schwenningen, Germany
    Posts
    11
    Hi Georg,

    I will contact you by email as well but just this entry for the others.

    Yes, to be precise, I mean triangles per frame.

    These are around 1000 per frame. As the code is not optimized yet, I am passing each triangle on its own, so the size of the vertex array is 3. It always happens after a specific point of time. If I leave the application right after I started it (some frames are rendered), everything works fine.

    The function eglMakeCurrent() just crashes. I will try to gather more information for you.

    If I comment out the glDrawArrays(), the crash never happens.

    Regards Norbert

Similar Threads

  1. PowerVR OpenGL | ES 2 SDK problem?
    By freber in forum OpenGL ES general technical discussions
    Replies: 0
    Last Post: 12-01-2008, 07:10 AM
  2. glFog bug in the 2700g PowerVR SDK?
    By hidefguy in forum OpenGL ES general technical discussions
    Replies: 3
    Last Post: 10-27-2005, 01:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •