Results 1 to 4 of 4

Thread: Problem with OpenGL/ES with Nokia S60 SDK v2.2

  1. #1
    Junior Member
    Join Date
    Oct 2004
    Location
    London
    Posts
    3

    Problem with OpenGL/ES with Nokia S60 SDK v2.2

    Hello,

    I had a problem running the example code for OpenGL/ES for Nokia S60 SDK. The code is descriped in the presentation by Vaarala in Khronos open university lectures (http://www.khronos.org/devu/library/)

    In more details the program will crash when run on the emulator (I think removing iLabel from ::ConstructL then calling SetExtentToWholeScreen() which in turn calls ::SizeChanged causes this problem).

    I would appreciate if anyone who managed to get the example running can let me know of the problems faced. It would also be helpful to point out any resources descriping a working GLES example on the Nokia's emulator.

    Thanks in advance.

  2. #2

    Re: Problem with OpenGL/ES with Nokia S60 SDK v2.2

    Hi.

    Did you remember to add the iGLInitialized shield to the SizeChanged function and ConstructL ?

    ConstructL should have in the beginning:

    iGLInitialized = EFalse;

    and towards the end (after full EGL initialization):

    iGLInitialized = ETrue;

    SizeChanged should have:

    if(iGLInitialized)
    {
    glViewport(....);
    }

    I hope this helps,

    --jani;

  3. #3

    Re: Problem with OpenGL/ES with Nokia S60 SDK v2.2

    Oh one more thing. Did you remember to cleanup the ConstructL, SizeChanged, ComponentControl, and CountComponentControl functions of the Label related stuff (as in the presentation) ?

    --jani;

  4. #4
    Junior Member
    Join Date
    Oct 2004
    Location
    London
    Posts
    3

    Re: Problem with OpenGL/ES with Nokia S60 SDK v2.2

    Hello,
    It works now. Thank you very much for your help.
    Cheers,
    Mo

Similar Threads

  1. Problem when running OpenGL ES app on Nokia S60 emulator
    By Fadi Chehimi in forum OpenGL ES general technical discussions
    Replies: 6
    Last Post: 01-27-2005, 01:31 PM
  2. bldmake problem with nokia sdk
    By adrian in forum OpenGL ES general technical discussions
    Replies: 0
    Last Post: 01-12-2005, 03:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •