Results 1 to 3 of 3

Thread: MFC and OPENGL ES initial problem?

  1. #1
    Junior Member
    Join Date
    Jun 2005
    Posts
    1

    MFC and OPENGL ES initial problem?

    My code like follwing, compiling had no problem but can not excute on 2003 emulation.
    Anyone know, how can I initial opengl es with MFC?
    Thank you

    EGLConfig configs[10];
    EGLint matchingConfigs;

    //configAttribs is a integers list that holds the desired format of
    //our framebuffer. We will ask for a framebuffer with 24 bits of
    //color and 16 bits of z-buffer. We also ask for a window buffer, not
    //a pbuffer or pixmap buffer
    const EGLint configAttribs[] =
    {
    EGL_RED_SIZE, 8,
    EGL_GREEN_SIZE, 8,
    EGL_BLUE_SIZE, 8,
    EGL_ALPHA_SIZE, EGL_DONT_CARE,
    EGL_DEPTH_SIZE, 16,
    EGL_STENCIL_SIZE, EGL_DONT_CARE,
    EGL_SURFACE_TYPE, EGL_WINDOW_BIT,
    EGL_NONE, EGL_NONE
    };

    hDC = ::GetDC(m_hWnd);
    glesDisplay = eglGetDisplay(hDC); //Ask for an available display

  2. #2
    Guest

    I also want to know the anwser of this question?

    How to built a project with MFC in ECV4.0?

  3. #3
    Senior Member
    Join Date
    Sep 2003
    Location
    Seattle, WA
    Posts
    246

    Re: MFC and OPENGL ES initial problem?

    Quote Originally Posted by cruccruc
    We will ask for a framebuffer with 24 bits of
    //color and 16 bits of z-buffer.
    On windows mobile, the framebuffer is R5-G6-B5. Maybe that's your problem?

    - HM

Similar Threads

  1. how to initial openg es with mfc, thank you
    By liudc in forum OpenGL ES general technical discussions
    Replies: 2
    Last Post: 12-01-2009, 05:27 AM
  2. Ogles problem in MFC Dialog Apps
    By Lorenzo in forum OpenGL ES 1.X - fixed function hardware
    Replies: 0
    Last Post: 09-07-2007, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •