Results 1 to 4 of 4

Thread: glFog bug in the 2700g PowerVR SDK?

  1. #1
    Junior Member
    Join Date
    Feb 2005
    Posts
    9

    glFog bug in the 2700g PowerVR SDK?

    I'm having problems using the PowerVR SDK for the Intel 2700g graphics chip (Dell X50V) - can someone confirm that fog calls are working properly - I am having major probs.
    Thanks

  2. #2
    Junior Member
    Join Date
    Mar 2005
    Location
    UK
    Posts
    24

    Re: glFog bug in the 2700g PowerVR SDK?

    This appears to be a bug with linear fog, and we're investigating the issue. As a workaround, you can change to exponential fog.

  3. #3
    Junior Member
    Join Date
    Feb 2005
    Posts
    9

    Re: glFog bug in the 2700g PowerVR SDK?

    <BLOCKQUOTE><font size="1" face="Arial, Verdana, Helvetica, sans-serif">quote:</font><HR>Originally posted by Aaron - PowerVR DevRel:
    This appears to be a bug with linear fog, and we're investigating the issue. As a workaround, you can change to exponential fog.<HR></BLOCKQUOTE>

    Tried that with no success; in my hands at least, all three fog modes (linear, exp, exp2) appear to be broken.

  4. #4
    Junior Member
    Join Date
    Mar 2005
    Location
    UK
    Posts
    24
    This issue was caused by a bug in the fixed-/floating-point abstraction macros we use in the PowerVR SDKs. It was fixed quite a long time ago now, the currently posted SDKs (http://www.pvrdev.com) being fine.

    Aaron.

Similar Threads

  1. PowerVR SDK Windows OpenGL ES 1.1 Bug
    By McNopper in forum OpenGL ES general technical discussions
    Replies: 2
    Last Post: 11-16-2006, 12:11 PM
  2. Which SDK of PowerVR i have to use!
    By beecatch in forum OpenGL ES general technical discussions
    Replies: 3
    Last Post: 10-31-2006, 03:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •