Results 1 to 5 of 5

Thread: Gerbera alloc panic on Symbian

  1. #1
    Junior Member
    Join Date
    Sep 2004
    Location
    Finland
    Posts
    11

    Gerbera alloc panic on Symbian

    I'm not sure if anyone can help me, but I'll try anyway. My Series 60 OpenGL ES application is working fine except that it's leaking memory. When I exit the app, I get an alloc panic. Debugging the panic I found out that some memory that is allocated inside eglCreateWindowSurface() is never freed. Here is my initializing code:

    Code :
     

    And here's the cleanup:

    Code :
     

    Anyone have ideas why something is not freed?

    [ October 07, 2004: Message edited by: Hege ]

  2. #2
    Junior Member
    Join Date
    Sep 2004
    Posts
    12

    Re: Gerbera alloc panic on Symbian

    Thank you for reporting this issue. We really appreciate it.

    Are you seeing this behaviour on the emulator or device version or both?

    We'll take a look at what's causing this and fix it in the next release. I assume the bug isn't affecting your development so that you don't need a fix earlier, right?

    How are you finding the library otherwise?

    Petri
    o Petri Kero, Systems Architect
    o Hybrid Graphics, Ltd. www.hybrid.fi

  3. #3
    Junior Member
    Join Date
    Sep 2004
    Location
    Finland
    Posts
    11

    Re: Gerbera alloc panic on Symbian

    No, this alloc panic is not a major problem at this point, I can ignore it for now. I'll post more info if/when I investigate it further.

    The application is only running on emulator so far, I've just started to test it on device (Currently somewhere in my code it's causing a EExcFloatUnderflow exception). On the emulator the library is working very well, no problems so far. I'm porting an existing OpenGL ES application from Windows CE platform.

    -Hege-

  4. #4
    Junior Member
    Join Date
    Sep 2004
    Location
    Finland
    Posts
    11

    Re: Gerbera alloc panic on Symbian

    Ok, now it's running on device also, without the alloc panic. So it shows up only on emulator.

  5. #5
    Junior Member
    Join Date
    Sep 2004
    Location
    Finland
    Posts
    11

    Re: Gerbera alloc panic on Symbian

    Update: Got rid of the alloc panic by changing the initialization. Previously I specified EGL_RED_SIZE 8, EGL_GREEN_SIZE 8, EGL_BLUE_SIZE 8, now I use EGL_BUFFER_SIZE.

Similar Threads

  1. floating point in the symbian gerbera implementaion
    By smsdev in forum OpenGL ES general technical discussions
    Replies: 0
    Last Post: 10-31-2004, 01:09 PM
  2. Problems running the gerbera sample symbian application
    By Hege in forum OpenGL ES general technical discussions
    Replies: 3
    Last Post: 09-15-2004, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •