Results 1 to 4 of 4

Thread: 2 Questions???

  1. #1
    Junior Member
    Join Date
    Oct 2004
    Location
    Rawalpindi, Pakistan
    Posts
    26

    2 Questions???

    Hi. I have two questions

    #1) I have used number of textures and sounds in my game, and checked on emulator (ppc 2003), at 2.8GHZ. At emulator the performance was satisafactory, but on 400mhz PPC 2003, IT WAS HORRIBLE, the objects were hardy able to move... How to improve performace using Textures ???

    #2) I have round 22 files which I have to copy one by one every time I connect a new device or emulator (via remote file viwer). isnt there any way possible to copy whole directory in the target device ???

  2. #2

    Re: 2 Questions???

    Regarding #1: You're first going to have to tell us what ES implementation you're using. But here's a few ideas, see if they help.

    a) Try GL_NEAREST texture filtering
    b) Try setting glHint(GL_PERSPECTIVE_CORRECTION_HINT, GL_FASTEST)
    c) Try setting glTexEnvf(GL_TEXTURE_ENV_MODE, GL_REPLACE)
    d) Try storing your textures at the same bit-depth and format as your screen surface

    - ben

  3. #3
    Junior Member
    Join Date
    Oct 2004
    Location
    Rawalpindi, Pakistan
    Posts
    26

    Re: 2 Questions???

    well I am using openGL ES Vencent 1.0. And what about copying whole directory to the target device???

  4. #4
    Senior Member
    Join Date
    Sep 2003
    Location
    Seattle, WA
    Posts
    246

    Re: 2 Questions???

    If you do not use texturing, how is your performance? i.e. is this a general rasterization issue, or just a texture issue? How large are your textures? Try to use mipmaps. Also, you might want to turn alpha-write off.

    For copying: Open the device in your Windows Explorer, you only need the Remote File Tool for 'hidden' files, like DLLs.

    - HM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •