Results 1 to 2 of 2

Thread: nullxcode test failure

  1. #1
    Junior Member
    Join Date
    Mar 2005
    Posts
    10

    nullxcode test failure

    I'm trying to check my OpenML build with the various test and example programs. I'm having some trouble with nullxcode and its test program.

    The nullxcode_test program bails out because the length of message[3] is returned as -1. Looking at nullxcode.c it appears to me that although it does fill in the requested value for ML_VIDEO_UST_INT64, it does not fill in the length.

    Is this a bug in nullxcode.c, or a bug in my understanding?

    ---JvdL---

  2. #2
    Member
    Join Date
    Jul 2003
    Location
    Montreal
    Posts
    75

    Re: nullxcode test failure

    I don't think this is a bug in nullXcode.

    It is more likely a bug in the test program, which has perhaps not been kept up to date. In this particular case, I don't know why the length of the UST param would become -1 (that *does* seem strange...), but in any case it seems that the test program is really trying to test the length associated with the buffer pointer, which is in message[1], not message[3]

    I'll make a note to look into this -- at the very least, fix up the test program (and also check why message[3].length is -1).

Similar Threads

  1. WebGL failure with Opera
    By kavi in forum WebGL - General
    Replies: 1
    Last Post: 05-23-2012, 07:22 AM
  2. Context failure because CL_DEVICE_NOT_AVAILABLE
    By petritis.erdas in forum OpenCL
    Replies: 2
    Last Post: 06-08-2011, 06:56 AM
  3. vidtogfx failure
    By caspar in forum OpenML Coding & Technical Issues
    Replies: 1
    Last Post: 08-25-2003, 10:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •