Results 1 to 3 of 3

Thread: mlGetCapabilities

  1. #1
    Junior Member
    Join Date
    Oct 2003
    Posts
    1

    mlGetCapabilities

    Hi everybody!
    I have a problem with this function... It returns 1000 after I call it and then when I call mlPvFind I get access violation. In the OpenML specification there is no 1000 status. What is wrong with my code?

    void Init()
    {
    char *buf = new char[40];
    MLstatus status;
    MLpv *systemCap;
    status = mlGetCapabilities( ML_SYSTEM_LOCALHOST, &systemCap);
    MLpv* deviceIds = mlPvFind(systemCap, ML_SYSTEM_DEVICE_IDS_INT64_ARRAY);
    if( deviceIds->length > 0 )
    {
    sprintf(buf, "%d", deviceIds->value.pInt64[0]);
    MessageBox(NULL, "", buf, MB_OK);
    }
    mlFreeCapabilities( systemCap );
    }

  2. #2

    Re: mlGetCapabilities

    Please have a look at
    ML/mldefs.h

    and the enumeration "mlStatusReturnEnum"
    around line 59.

  3. #3
    Member
    Join Date
    Jul 2003
    Location
    Montreal
    Posts
    75

    Re: mlGetCapabilities

    You could also use the function:
    const char* mlStatusName( MLstatus status )

    to get the "text" version of your error code.

    That said, code 1000 is "internal error". I suppose that could mean a number of things, but most likely is that your ML daemon is not running. The daemon must be running in order for any ML program to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •