That is an old driver. Try upgrade to 9.10, or try using ppa ubuntu x-updates. The new intel driver may support glsl > 1.10.