Try adding -DCL_USE_DEPRECATED_OPENCL_1_1_APIS as a compiler option while keeping the 1.2 headers. This yields a friendly
warning: #warning CL_USE_DEPRECATED_OPENCL_1_1_APIS is defined. These APIs...