Search:

Type: Posts; User: kaesemeister

Search: Search took 0.00 seconds.

  1. clCreateFromGLTexture2D returns CL_INVALID_GL_OBJECT (-60)

    Hi, I can't get "clCreateFromGLTexture2D" to work.. here is the relevant code:



    glGenTextures(1, &t);
    glBindTexture(GL_TEXTURE_2D, t);
    glTexParameteri(GL_TEXTURE_2D, GL_TEXTURE_MIN_FILTER,...
  2. Replies
    10
    Views
    3,574

    Re: CL_INVALID_GL_OBJECT

    do you mean this situation?


    if yes: I didn't tried to update to the newest version
    if not and you refer to the problem of the topic, updating the ADM driver solved the problem.
  3. Replies
    10
    Views
    3,574

    Re: CL_INVALID_GL_OBJECT

    It worked with 8.881-110728a-122950C-ATI. I did not tested other versions..

    Now I got the next problem which is maybe jocl specific..
    I get unknown failure messages (varying numeric failure...
  4. Replies
    10
    Views
    3,574

    [SOLVED] Re: CL_INVALID_GL_OBJECT

    thank you all!
    the problem is solved. I've done these simple steps:

    - downloaded some recent driver (not the newest) from ATI
    - uninstalled driver packages (apt-get remove --purge fglrx*)
    -...
  5. Replies
    10
    Views
    3,574

    Re: CL_INVALID_GL_OBJECT

    thanks for your answer. I will try to post this in another forum.

    I've done some more tests to find out what's the problem: The AMD SDK delivers some c examples. I compiled them and get the same...
  6. Replies
    10
    Views
    3,574

    CL_INVALID_GL_OBJECT

    Hi,

    I startet experimenting with OpenCL. First tests are done. Now I am trying to check out Interoperability with OpenGL. I want to manipulate an OpenGL Buffer directly.. I'm working with jogamp...
Results 1 to 6 of 6