I will put forward that you should have a computer that has support for OpenGL 1.5 or higher.

There is a wrapper library that you can download from here called something like dgles. As I recall,...