PDA

View Full Version : OpelCL doesn't see my ATI 5870



daehenoc
06-22-2011, 06:34 PM
Hi all,

I have an ATI 5870 video card and I have installed it in an Ubuntu 10.04 host. This host is a headless MythTV server, it hasn't had the X system installed on it. I have put the latest ATI drivers on, and got OpenCL installed by following various instructions I found:
http://deekayen.net/node/1317
http://sectio-aurea.blogspot.com/2011/0 ... natty.html (http://sectio-aurea.blogspot.com/2011/05/bitcoin-mining-on-ubuntu-1104-natty.html)
http://forum.bitcoin.org/index.php?topic=9239.0

I've installed the fglrx drivers using dpkg, and used sudo as per instructions to install various python bits and opencl. I'm using ssh to do all of this work, I'm not actually on the console.

When I run clinfo, I only get information for the CPU in the system:

$ ./clinfo | grep Name
Name: Intel(R) Core(TM)2 Duo CPU E7400 @ 2.80GHz
I've got X running via startx and I can run fglrxinfo:

$ DISPLAY=:0 sudo fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5800 Series
OpenGL version string: 4.1.10834 Compatibility Profile Context
For some reason the card is listed as a 6898 in lspci:

$ lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Device 6898

I suspect that the reason clinfo can't see the video card is because of the kernel version this box has:

$ uname -a
Linux mythtv-server 2.6.32-32-server #62-Ubuntu SMP Wed Apr 20 22:07:43 UTC 2011 x86_64 GNU/Linux

I'll try installing a newer kernel, but in the meantime, if anyone has any hints I can try, please let me know!

Thanks!

daehenoc
06-22-2011, 06:43 PM
Damn, I've installed 2.6.38, to no avail:

$ uname -a
Linux mythtv-server 2.6.38-8-server #42~lucid1-Ubuntu SMP Mon Apr 11 14:52:09 UTC 2011 x86_64 GNU/Linuxclinfo still does not see the video card.