PDA

View Full Version : unable to use opengl on ubuntu9.10, chrome or firefox



meir
04-03-2010, 07:41 AM
I am trying to run web-gl and can't get even the simplest example to work.
I am run ubuntu 9.10 on a dell inspiron 1420 with intel 965 card.
glgears works fine and glinfo says:
...
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.6
OpenGL shading language version string: 1.20
...

I am using nightly builds of both chrome and firefox.
chrome with --enable-webgl --no-sandbox
firefox enabling webgl.enabled_for_all_sites and trying both with and with out webgl.software_render

I am using the test: http://learningwebgl.com/tests/cruftcheck20100104.html
and I can not get a context using any of the strings used.

any ideas?

Meir.

SteveBaker
10-13-2010, 07:51 PM
The trouble is that this series of Intel chip only has OpenGL 1.2 (which is horribly ancient - and doesn't support shaders at all - and hence isn't good enough to host WebGL).

Under Windows XP, you can use Chrome - which converts WebGL to DirectX 9 - which the Intel chip just barely supports. However, it's painfully slow because vertex shaders are run in the CPU and the fragment shaders are slow because they are just not built for the kinds of speed that you expect from a modern graphics system. In theory, Firefox under windows will eventually do that too - but it's unlikely that this GPU will ever run WebGL under Linux.

If this is a deskside computer - you're going to need a new graphics card (buy one with an nVidia or ATI chip!) - if it's a laptop, then you're screwed. You might (maybe) be able to fall back to running Mesa (an implementation of OpenGL running entirely in CPU software) - but that would be exceedingly slow for most 3D applications - and I have no idea whether it actually works with WebGL or not.