PDA

View Full Version : error building Nokia 3d example



miranda2112
02-20-2005, 04:26 PM
Hi,
I am trying to build an run the simplecube example that comes with the "Series 60 Developer Platform: Introduction To 3-D Graphics In C++ (With Example) v1.1 (ZIP)" from Forum Nokia (http://www.forum.nokia.com/main/0,,1_50_4,00.html).

I have not altered any code, and I have all my gl and egl .h files in the epoc 32 include directory and the vc7 include directory.

I am using Visual Studio .NET 2003 and I am creating a .sln file by running the "makmake simplecube vc7 command".

When I try to build the solution created by makmake I get a number of errors that mostly look like this:

SIMPLECUBE error LNK2019: unresolved external symbol __imp__glHint referenced in function "public: void __thiscall CSimpleCube::AppInit(void)" (?AppInit@CSimpleCube@@QAEXXZ)

The last 3 errors are:

SIMPLECUBE fatal error LNK1120: 27 unresolved externals

SIMPLECUBE fatal error U1077: 'link.exe' : return code '0x460'

SIMPLECUBE fatal error LNK1181: cannot open input file '\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIAN\7 .0S\SERIES60_V21\SERIES60EX\3DEXAMPLES\OPENGLEX\SI MPLECUBE\GROUP\SIMPLECUBE\WINS\UDEB\SIMPLECUBE.exp '


Any help would be greatly appreciated!
Miranda

[ February 20, 2005: Message edited by: miranda2112 ]

flame
02-22-2005, 01:35 AM
Hi Miranda.

Did you post this also to http://forum.nokia.com? (http://forum.nokia.com) This is the official forum for Nokia SDK related questions.

A colleague of mine suggested that changing to newest version of the SDK could fix the problem.

Judging from the error log, you are using really old version of the SDK NOT supporting OpenGL ES:

"SIMPLECUBE fatal error LNK1181: cannot open input file '\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIAN\7 .0S\SERIES60_V21\SERIES60EX\3DEXAMPLES\OPENGLEX\SI MPLECUBE\GROUP\SIMPLECUBE\WINS\UDEB\SIMPLECUBE.exp '"

FP2 SDK location should actually be something like 8.0a, not 7.0s.

--jani;

[ February 22, 2005: Message edited by: Jani Vaarala ]

miranda2112
02-23-2005, 01:22 PM
Thanks for the reply.

I can compile and run a different 3d example using OpenGL ES, which is what makes this extra strange...

Would FP2 be compatible with a Nokia 6600?

Thanks

flame
02-23-2005, 10:43 PM
Hi.

6600 doesn't have OpenGL ES preinstalled on the device firmware/hardware. 6630 is the first device which has public OpenGL ES API exposed and the OpenGL ES API support comes with the device itself.

If you want to get OpenGL ES running on 6600, you need to get OpenGL ES SW implementation such as Gerbera from Hybrid or Vincent.

I hope this helps,

--jani;

[ February 24, 2005: Message edited by: Jani Vaarala ]