PDA

View Full Version : GLUT|ES link problems



nadadani
03-05-2005, 02:05 AM
Hi!

I tried to link my projects in EVC 4.0 using glutes libraries. My settings were: Pocket PC 2003, WCE emulator (Debug), Pocket PC 2003 emulator.

The erroe message was:

uborotgener.obj : error LNK2019: unresolved external symbol __imp__glutMainLoop referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutReshapeFunc referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutDisplayFunc referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutCreateWindow referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutInitWindowSize referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutInit referenced in function _main
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutSwapBuffers referenced in function "public: void __thiscall VRMLscene::display(void)" (?display@VRMLscene@@QAEXXZ)
cuborotgener.obj : error LNK2019: unresolved external symbol __imp__glutPostRedisplay referenced in function "public: void __thiscall VRMLscene::display(void)" (?display@VRMLscene@@QAEXXZ)
emulatorDbg/cuborotgener.exe : fatal error LNK1120: 8 unresolved externals
Error executing link.exe.

Is there anyone that can help me?

Thank you in advance.

www.rzr.online.fr
10-18-2005, 09:24 AM
it worked on ARM mode here