PDA

View Full Version : Problem when running OpenGL ES app on Nokia S60 emulator



Fadi Chehimi
01-23-2005, 03:29 PM
Regards,
i am trying to run some OpenGL ES applications on Nokia Series 60 SDK 2.0 but they are not working. the code gets compiled without any error. but when i try to run it, it terminates and returns to the menu screen without doing anything. when i build it and make it for the device (ARMI), it runs properly.
any suggestions???

(note that i copied all the needed header files and libraries from SDK2 FP2 to SDK2.0)

flame
01-24-2005, 11:50 AM
Hi.

So you are not using the FP2 SDK but an older SDK? That may not work as the header files and libraries may have been built against the FP2 SDK. I'm not sure, but that may be the case.

--jani;

Fadi Chehimi
01-25-2005, 02:24 AM
Hi Jani,

i tried to do as u did in ur demonstration in DevU presentation in London where u used SDK 2.0 (Symbian 7.0). i remember that u used that SDK not FP2. How did u do that in this case?

Fadi

flame
01-26-2005, 10:31 AM
Hi.

I had then a special internal development version of the engine. It probably does not work in 2.0 if you just take the DLL's there.

Is there any reason why you aren't using the FP2 SDK?

--jani;

Fadi Chehimi
01-26-2005, 01:18 PM
yes there is a reason!!!
a very big reason :S
simply, the SDK FP2 is not working. i am trying to run any application on the SDK FP2 for CodeWarrier, not only openGL ES ones, and i always get the following EPOCROOT error:

Error : Symbian Resource - ERROR: Must set the EPOCROOT environment variable BEGIN failed--compilation aborted at C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\tools/E32env.pm line 51. Compilation failed in require at C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\tools/epocrc.pl line 27. BEGIN failed--compilation aborted at C:\Symbian\8.0a\S60_2nd_FP2_CW\epoc32\tools/epocrc.pl line 27.

i have other 3 SDKs on my sys (1.2, 2.0, 2.1) and all are working fine. i tried to reset the epocroot in the env sys var in cont panel, but it didnt work. i even tried to reset the default device config from the prompt, also it didnt work.

i dont know what to do espicially that CodeWarrier deals with epocroot automatically.
so, if u can help me solving this problem, i will be so much grateful.

Thanx
Fadi

flame
01-26-2005, 11:25 PM
Hi.

Have you tried the VC6 and .NET version of the FP2 SDK yet?

If you have issues with the SDK's, www.forum.nokia.com (http://www.forum.nokia.com) people should be able to help.

--jani;

Fadi Chehimi
01-27-2005, 01:31 PM
Hi Jani,
i managed at the end to have the code running on VC6. i gave up with CW fro the mean time.
any ways, thank u very much for ur help.
i appriciate it.

Fadi