PDA

View Full Version : Gerbera alloc panic on Symbian



Hege
10-06-2004, 10:44 PM
I'm not sure if anyone can help me, but I'll try anyway. My Series 60 OpenGL ES application is working fine except that it's leaking memory. When I exit the app, I get an alloc panic. Debugging the panic I found out that some memory that is allocated inside eglCreateWindowSurface() is never freed. Here is my initializing code:




And here's the cleanup:




Anyone have ideas why something is not freed?

[ October 07, 2004: Message edited by: Hege ]

jabatti
10-07-2004, 03:25 AM
Thank you for reporting this issue. We really appreciate it.

Are you seeing this behaviour on the emulator or device version or both?

We'll take a look at what's causing this and fix it in the next release. I assume the bug isn't affecting your development so that you don't need a fix earlier, right?

How are you finding the library otherwise?

Petri

Hege
10-07-2004, 10:31 PM
No, this alloc panic is not a major problem at this point, I can ignore it for now. I'll post more info if/when I investigate it further.

The application is only running on emulator so far, I've just started to test it on device (Currently somewhere in my code it's causing a EExcFloatUnderflow exception). On the emulator the library is working very well, no problems so far. I'm porting an existing OpenGL ES application from Windows CE platform.

-Hege-

Hege
10-08-2004, 03:19 AM
Ok, now it's running on device also, without the alloc panic. So it shows up only on emulator.

Hege
01-04-2005, 10:36 PM
Update: Got rid of the alloc panic by changing the initialization. Previously I specified EGL_RED_SIZE 8, EGL_GREEN_SIZE 8, EGL_BLUE_SIZE 8, now I use EGL_BUFFER_SIZE.