PDA

View Full Version : 2 Questions???



qasim1981
02-14-2005, 08:45 AM
Hi. I have two questions

#1) I have used number of textures and sounds in my game, and checked on emulator (ppc 2003), at 2.8GHZ. At emulator the performance was satisafactory, but on 400mhz PPC 2003, IT WAS HORRIBLE, the objects were hardy able to move... How to improve performace using Textures ???

#2) I have round 22 files which I have to copy one by one every time I connect a new device or emulator (via remote file viwer). isnt there any way possible to copy whole directory in the target device ???

bentlegen
02-15-2005, 04:45 AM
Regarding #1: You're first going to have to tell us what ES implementation you're using. But here's a few ideas, see if they help.

a) Try GL_NEAREST texture filtering
b) Try setting glHint(GL_PERSPECTIVE_CORRECTION_HINT, GL_FASTEST)
c) Try setting glTexEnvf(GL_TEXTURE_ENV_MODE, GL_REPLACE)
d) Try storing your textures at the same bit-depth and format as your screen surface

- ben

qasim1981
02-15-2005, 07:14 AM
well I am using openGL ES Vencent 1.0. And what about copying whole directory to the target device???

hmwill
02-15-2005, 04:34 PM
If you do not use texturing, how is your performance? i.e. is this a general rasterization issue, or just a texture issue? How large are your textures? Try to use mipmaps. Also, you might want to turn alpha-write off.

For copying: Open the device in your Windows Explorer, you only need the Remote File Tool for 'hidden' files, like DLLs.

- HM