PDA

View Full Version : debugging the SDK



ehsan2004
07-19-2004, 03:24 PM
Dear Fabrice
for debbuging the SDK, when i give the SET_ENV command, i receive the following message:
'SET_ENV' is not recognized as an internal or external command, operable program or batch file.
i think that the reason is that it's a bash shell window. what's the solution?
best regards
Ehsan Kamrani

fjaubert
07-21-2004, 03:24 PM
For sh/bash, use 'export'

ehsan2004
07-22-2004, 03:55 AM
Dear Fabrice
note that i use from the "Command prompt" that's available in XP. it also reports me the same message when i use the "export" command.
regards
...Ehsan

[ July 22, 2004: Message edited by: ehsan2004 ]

fjaubert
07-27-2004, 03:18 AM
The ML development environment is designed to work with cygwin's 'bash' or 'tcsh' shells (as noted in the release notes). If you wish to use Windows' command prompt, you will need to experiment. That configuration is not officially supported.

ehsan2004
10-03-2004, 10:56 PM
Hi
I have downloaded the cygwin and replaced the bash shell with tcsh shell. I want to compile the sdk on windows. I have extracted the sdk-source.zip to the following path:
e:\openml\sdk-source
after i go to the this path, i issue the command ./SET_ENV
After a small interrupt, nothing happens and again i see the selected path on the shell window.What's the problem?please suggest me.
Ehsan

[ October 04, 2004: Message edited by: ehsan_kamrani ]

fjaubert
10-13-2004, 08:41 AM
In order to use the SET_ENV shell script, you must 'source' it from your (tcsh) shell:

% source SET_ENV

This will set all necessary variables so that you may use your shell to compile the SDK.