Khronos Public Bugzilla
Bug 410 - Proposal for OES_standard_derivatives extension
Proposal for OES_standard_derivatives extension
Status: RESOLVED FIXED
Product: WebGL
Classification: Unclassified
Component: Registry
1.0
All All
: P3 normal
: ---
Assigned To: 3dweb Working Group email alias
:
: 408 409 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-13 16:21 PST by Ben Vanik
Modified: 2011-01-13 22:26 PST (History)
1 user (show)

See Also:


Attachments
patch for extension registry (3.42 KB, patch)
2011-01-13 16:21 PST, Ben Vanik
Details | Diff
Additional comment about about getParameter (785 bytes, patch)
2011-01-13 20:21 PST, Ben Vanik
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Vanik 2011-01-13 16:21:21 PST
Attached is a patch adding the OES_standard_derivatives extension to the registry as WebGL Extension #4.
Comment 1 Ben Vanik 2011-01-13 16:21:58 PST
Created attachment 65 [details]
patch for extension registry
Comment 2 Kenneth Russell 2011-01-13 19:18:52 PST
Thanks for the patch. It's been committed with a slight modification to indicate that the #enable directive is still required in the fragment shader.
Comment 3 Ben Vanik 2011-01-13 20:21:35 PST
Created attachment 66 [details]
Additional comment about about getParameter

getParameter should accept FRAGMENT_SHADER_DERIVATIVE_HINT_OES when OES_standard_derivatives is enabled. This patch adds a note to the Overview saying such.
Comment 4 Kenneth Russell 2011-01-13 20:40:17 PST
Committed.
Comment 5 Ben Vanik 2011-01-13 22:26:25 PST
*** Bug 408 has been marked as a duplicate of this bug. ***
Comment 6 Ben Vanik 2011-01-13 22:26:38 PST
*** Bug 409 has been marked as a duplicate of this bug. ***