Khronos Public Bugzilla
Bug 367 - WFCT_Utils_testElementBooleanAttrib: incorrect checking of the return code
WFCT_Utils_testElementBooleanAttrib: incorrect checking of the return code
Status: RESOLVED INVALID
Product: OpenWF
Classification: Unclassified
Component: Conformance Tests
unspecified
All All
: P3 major
: ---
Assigned To: Robert Palmer
Composition work group email alias
:
: 368 369 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 04:44 PDT by Cyril PROTAT
Modified: 2010-11-09 06:08 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril PROTAT 2010-10-22 04:44:11 PDT
In the wfc_test_utils.c file, the function "WFCT_Utils_testElementBooleanAttrib" tests the setting of an incorrect parameter : 

[ wfc_test_utils.c, line 224]

"/* Set bad handle (float) */"
wfcSetElementAttribf(appCtx->dev, WFC_INVALID_HANDLE, attrib, expectedf);
WFCT_CHECK_ERROR(WFC_ERROR_BAD_ATTRIBUTE, "Raised wrong or no error for bad handle (float setter).");
valuef = wfcGetElementAttribf(appCtx->dev, WFC_INVALID_HANDLE, attrib);
WFCT_CHECK_ERROR(WFC_ERROR_BAD_ATTRIBUTE, "Raised wrong or no error for bad handle (float getter).");

The return code for such an invalid attribute (WFC_INVALID_HANDLE) should be (and actually is) WFC_ERROR_BAD_HANDLE, not WFC_ERROR_BAD_ATTRIBUTE as in the above code.
Comment 1 lars.f.persson 2010-11-09 06:06:30 PST
Moved this bug to internal Bugzilla.
Comment 2 lars.f.persson 2010-11-09 06:07:21 PST
*** Bug 368 has been marked as a duplicate of this bug. ***
Comment 3 lars.f.persson 2010-11-09 06:08:42 PST
*** Bug 369 has been marked as a duplicate of this bug. ***